GM Volt Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
I'm so close to finally have this working. I purchased the Wifi version, but am using USB to keep it simple for now.

Here's where I'm stuck: VX Manager, VCI Manager and GDS2 all seem to be installed okay (including rar patch).

Did not install t2win. GM MDI Manager has initialization error.

GDS2 starts just fine. Diagnostics show MDI & MDI 2 suppported.
VXDIAG says "Please Contact the Device Manufacturer". Click on continue for it, and it goes to vehicle selection. Acts like it's talking to the Volt (ignition on, not running, blue flashing, solid red) but won't retrieve VIN. If I try to run diagnostics of any kind, it runs down the list saying "no communication", just like if I have it unplugged from the Volt.

I've been through so many tutorials to get this far I'm exhausted. What am I missing at this point? I would really appreciate any tips on this.

**Goal is to purchase AC Delco SPS, but not until I'm sure I can get the VCX to communicate with the Volt.
 

·
Registered
Joined
·
2,356 Posts
I'm so close to finally have this working. I purchased the Wifi version, but am using USB to keep it simple for now.

Here's where I'm stuck: VX Manager, VCI Manager and GDS2 all seem to be installed okay (including rar patch).

Did not install t2win. GM MDI Manager has initialization error.

GDS2 starts just fine. Diagnostics show MDI & MDI 2 suppported.
VXDIAG says "Please Contact the Device Manufacturer". Click on continue for it, and it goes to vehicle selection. Acts like it's talking to the Volt (ignition on, not running, blue flashing, solid red) but won't retrieve VIN. If I try to run diagnostics of any kind, it runs down the list saying "no communication", just like if I have it unplugged from the Volt.

I've been through so many tutorials to get this far I'm exhausted. What am I missing at this point? I would really appreciate any tips on this.

**Goal is to purchase AC Delco SPS, but not until I'm sure I can get the VCX to communicate with the Volt.

The following is what I did to get my gen1 to work with VCXNano via SPS:

You have to get GMs J2534 Wrapper to install successfully. I did this by executing old legacy IE in administrator mode to logon to ACDelco TDS (right click select 'run as administrator')
You only have to do this once. After the J2543 Wrapper is installed you can run java normally not as administrator



After you launch SPS java select run above




Again, select run at the above dialog box





You don't need MIDI or Tech2 drivers to do any SPS programming...just the J2534 Wrapper as shown above then hit Install button




If java was executed as administrator, you will get the above showing J2534 Wrapper was installed successfully...if you didn't run as administrator it will fail




Now you should be able to select the J2543 Tool in order to push firmware onto your volt..SPS should now be able to read VIN w/o issue!;)
 

·
Registered
Joined
·
24 Posts
I'm so close to finally have this working. I purchased the Wifi version, but am using USB to keep it simple for now.

Here's where I'm stuck: VX Manager, VCI Manager and GDS2 all seem to be installed okay (including rar patch).

Did not install t2win. GM MDI Manager has initialization error.

GDS2 starts just fine. Diagnostics show MDI & MDI 2 suppported.
VXDIAG says "Please Contact the Device Manufacturer". Click on continue for it, and it goes to vehicle selection. Acts like it's talking to the Volt (ignition on, not running, blue flashing, solid red) but won't retrieve VIN. If I try to run diagnostics of any kind, it runs down the list saying "no communication", just like if I have it unplugged from the Volt.

I've been through so many tutorials to get this far I'm exhausted. What am I missing at this point? I would really appreciate any tips on this.

**Goal is to purchase AC Delco SPS, but not until I'm sure I can get the VCX to communicate with the Volt.
Congratulations, you got a lot further than I did. I bailed when I realized that in order to run the thing I had to disable virus protection and download files from some unknown Chinese website. Not goin' there.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #4 ·
The following is what I did to get my gen1 to work with VCXNano via SPS:

You have to get GMs J2534 Wrapper to install successfully. I did this by executing old legacy IE in administrator mode to logon to ACDelco TDS (right click select 'run as administrator')
You only have to do this once. After the J2543 Wrapper is installed you can run java normally not as administrator

Now you should be able to select the J2543 Tool in order to push firmware onto your volt..SPS should now be able to read VIN w/o issue!;)
Thanks a lot for this. I just got the VXDiag to talk to the Volt tonight, and feel like I can order the SPS with a little more confidence now.
Thanks for the great walk-through!
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #5 · (Edited)
It worked!!!!!
The reprogram got stuck after 100%, but it allowed it to charge right after. I will go back and reprogram the BECM next - it's updated but I understand it should be flashed after this, and any other DTCs removed.

Thanks for your help on this!
 

·
Registered
Joined
·
2,356 Posts
It worked!!!!!
The reprogram got stuck after 100%, but it allowed it to charge right after. I will go back and reprogram the BECM next - it's updated but I understand it should be flashed after this, and any other DTCs removed.

Thanks for your help on this!

Glad to hear it worked!(y)


you must open passthu app



BTW: Only have to install PASSTHRU when installing VX Manager app if all you are doing is SPS programming...you don't need to open the VX Manager app to use SPS
It is a good idea to check if your VCX Nano is running the latest firmware using the VX Manager app though...
 

·
Registered
Joined
·
2 Posts
Glad to hear it worked!(y)







BTW: Only have to install PASSTHRU when installing VX Manager app if all you are doing is SPS programming...you don't need to open the VX Manager app to use SPS
It is a good idea to check if your VCX Nano is running the latest firmware using the VX Manager app though...

Hello,

im trying to reprogramming the same thing, but went i click in the k114B module, its appear an error "E4398", and the proccess stop. Do i need to open the passthru thru vxmanager to avoid this or there is another issue?

172300
 

·
Registered
Joined
·
1 Posts
Glad to hear it worked!(y)








BTW: Only have to install PASSTHRU when installing VX Manager app if all you are doing is SPS programming...you don't need to open the VX Manager app to use SPS
It is a good idea to check if your VCX Nano is running the latest firmware using the VX Manager app though...
Im getting the error E4403 was unable to read the VIN. I tried installing only the wrapper and not installing the other updates. Tech2win works perfectly but the SPS fails one I select the vehicle model and E4403 pops up. Do I need to have Pasthru J2534 Tool open or connected or certain protocol ID or Load DLL or something active?
 
1 - 10 of 10 Posts
Top