GM Volt Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I was having trouble with the voice commands on my 2017 Premier. The dealer told me it was probably a phone issue but when I took the car in the Volt Tech had the same issue with his phone once it was paired. He had no idea what was causing it so he call GM Tech support. It seems that Volts get what he called a "logic lock" and the voice commands stop working. What needs to be done to fix the issue it to go into settings, change the language to Spanish (not sure if other languages will work) then shut down the car for 5 minutes. Go back into the system and change the language back to English and the voice commands will work fine.

I'm not sure why this works but it dose and I haven't had any problem since.

I hope this helps.
 

·
Registered
Joined
·
5,782 Posts
So, the language is not set from the factory? Seems kind of a wacko fix, but, I've seen worse before in other software.
 

·
Registered
Joined
·
518 Posts
I was having trouble with the voice commands on my 2017 Premier. The dealer told me it was probably a phone issue but when I took the car in the Volt Tech had the same issue with his phone once it was paired. He had no idea what was causing it so he call GM Tech support. It seems that Volts get what he called a "logic lock" and the voice commands stop working. What needs to be done to fix the issue it to go into settings, change the language to Spanish (not sure if other languages will work) then shut down the car for 5 minutes. Go back into the system and change the language back to English and the voice commands will work fine.

I'm not sure why this works but it dose and I haven't had any problem since.

I hope this helps.
I had the exact same issue on my 2017 Premier. Left the car at the dealer for a week while I went on vacation and when I got back, the dealer told me of the same "fix". It has worked fine ever since.
 

·
Registered
Joined
·
788 Posts
My 2011 Dodge Journey has an interesting bug where the software in the radio amplifier locks up causing the car to lose all internal sounds, beeps, audio, etc... The fix is to either disconnect the battery or pull the power plug from the amp and then reconnect which reboots the software.

Gotta love modern cars and the bugs that come along with them.
 

·
Registered
Joined
·
134 Posts
My 2017 Volt Premier doesn't hear me say "Yes"! I push the voice button and say "Call Joe Smith Mobile". My Car says: "If you want to call Joe Smith Mobile, say Yes". I say "Yes". Car says it didn't hear me. Of course I'm yelling "Yes Yes Yes". Car ends up saying "I haven't received a response, goodbye". (Or whatever it says)

Why won't my car hear me say "Yes"?
 

·
Registered
Joined
·
322 Posts
My 2017 Volt Premier doesn't hear me say "Yes"! I push the voice button and say "Call Joe Smith Mobile". My Car says: "If you want to call Joe Smith Mobile, say Yes". I say "Yes". Car says it didn't hear me. Of course I'm yelling "Yes Yes Yes". Car ends up saying "I haven't received a response, goodbye". (Or whatever it says)

Why won't my car hear me say "Yes"?
Have you tried the fix described above?
 

·
Registered
Joined
·
134 Posts
I finally got around to doing the fix in the OP. Haven't put it back to English yet. I'll report back with the results later.
 

·
Registered
Joined
·
677 Posts
My problem is that the voice recognition in the car is simply mediocre at best. When I say, "Call XXX on the mobile", for example, it will often pick the wrong name... Android Auto, on the other hand, has never made a mistake.
 

·
Registered
Joined
·
968 Posts
My problem is that the voice recognition in the car is simply mediocre at best. When I say, "Call XXX on the mobile", for example, it will often pick the wrong name... Android Auto, on the other hand, has never made a mistake.
That has alos been my observation as well. MyLink is ok, AA is great.
 

·
Registered
Joined
·
134 Posts
>>>I'll report back with the results later. <<<

Nope. I reinstated English. Tried to make a call. It understands everything I say until it asks for "Yes". I say it 20 times and it says "I have heard no response, good bye".
 

·
Registered
Joined
·
134 Posts
I'm going to bump this again, guys. I still have this problem and I'm about to take my first long trip. 11 hours from N.E. NC to Rochester, NY. It would be nice if my car understood when I say yes!?? Anybody else here have any issues with speech recognition?
 

·
Registered
Joined
·
2,773 Posts
I'm going to bump this again, guys. I still have this problem and I'm about to take my first long trip. 11 hours from N.E. NC to Rochester, NY. It would be nice if my car understood when I say yes!?? Anybody else here have any issues with speech recognition?
So, your car understands when you say "call John Smith" but doesn't understand the word "yes". Are you waiting for the beep before you say "yes"? And you are NOT pushing the talk button for your reply, right?
 

·
Registered
Joined
·
134 Posts
So, your car understands when you say "call John Smith" but doesn't understand the word "yes". Are you waiting for the beep before you say "yes"? And you are NOT pushing the talk button for your reply, right?
TSquare, thanks for your reply.

Yes, it seems to understand my request for "call john smith mobile". The car then says: "If this is correct say "Yes". I say yes and it doesn't hear that simple word. Waiting for a beep? I don't remember a beep, it suggests to say yes, and I say Yes.

What was funny a couple days ago I was saying "Yes, yes, yes, yes and it finally dialed........"john smiths" WIFES phone! Ahhhhhh. I only push the talk button at the very beginning to start the session. I've done the change to Spanish, shut down, start up change back to English. No go.
 

·
Registered
Joined
·
2,773 Posts
TSquare, thanks for your reply.

Yes, it seems to understand my request for "call john smith mobile". The car then says: "If this is correct say "Yes". I say yes and it doesn't hear that simple word. Waiting for a beep? I don't remember a beep, it suggests to say yes, and I say Yes.

What was funny a couple days ago I was saying "Yes, yes, yes, yes and it finally dialed........"john smiths" WIFES phone! Ahhhhhh. I only push the talk button at the very beginning to start the session. I've done the change to Spanish, shut down, start up change back to English. No go.
I can't find the specific instructions in the manual, but I'm pretty sure that any time the system asks for a response it plays a beep (tone) to signal that it is listening. It does not hear anything until after the beep.
 
1 - 14 of 14 Posts
Top