GM Volt Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
My 2018 Volt plug-in to the car has always been a chore. After 10 months, I had hoped it would loosen up, but no dice.

Any solutions to this issue? TIA
 

·
Administrator
Joined
·
20,018 Posts
Phew, Based on the title I was wondering if I'd have to move this thread to the non-public forum, haha.

You could try lightly sanding the outside of the handle port ring with fine sandpaper. Remember you can always take more off, can't put it back on. Too lose is also a problem.
 

·
Registered
Joined
·
1,886 Posts
I had the same issue. Put a light bit of silicone spray in the Male end and it has been perfect since.
I have the same problem with my OpenEVSE charge station; the J1772 handle I got from Quick Charge Power is hard to plug in. I've sanded the outside of the handle port ring without success. I've also used silicone spray, but that seemed to make it worse; almost seemed like it made the plastic swell a little bit.

I've learned to align the handle to the port as precisely as I can; that's about the only thing that seems to work. I've had no such problem with my old Voltec EVSE's J1772 handle.
 

·
Registered
Joined
·
1,189 Posts
Same problem with one of my duosidas, particularly when disconnecting. The other is fine. Thought it would loosen up with time but it has not. Have to wiggle it out.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
I have the same problem with the J1772 plug on my OpenEVSE. I have been using a very light spray of WD40 on it. After a year or so it has finally improved a bit. I have never had a tight fit problem with the J1772 plugs on ChargePoint or EVgo stations.
 
1 - 8 of 8 Posts
Top