GM Volt Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hello . Who can help with that ? Have error Code P1FFF and P0AA6. Service Hight Voltage Charging System . Then reprogrammed K114B HPCM2 . Error still on . Then reprograming K16 and on 3116 byte programing is stoped and error message is E4491 . Car is dead . Then removed battery pack and replace K16 BECM ( battery energy control module ) . Car is starts but first problem still on . Today i tryed reprogramm new BECM and programming stoped at 3116 byte!! Dead second BECM . Car now is dead and errors you can see on photo. Anybody can help ?
 

·
Registered
Joined
·
307 Posts
Seams you are on the right track with these codes, there is a update for the BECM for the p1fff and the p0aa6. Programming the Battery Energy Control Module should be easy but you have to remember that when programming the BECM, the status bar will show the program is complete but the actual programming is not finished yet. Not until the status bar page switches over to the finished page. This is abnormal, when programming all other modules you do not get this delay. The delay may take up to 10 minutes before the program is complete. Make sure you have n done this or you will have issues.
Do you get the error code while programming or after programming? E4491?
Do you get the U185a prior to programming the BECM or after the programming error?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Seams you are on the right track with these codes, there is a update for the BECM for the p1fff and the p0aa6. Programming the Battery Energy Control Module should be easy but you have to remember that when programming the BECM, the status bar will show the program is complete but the actual programming is not finished yet. Not until the status bar page switches over to the finished page. This is abnormal, when programming all other modules you do not get this delay. The delay may take up to 10 minutes before the program is complete. Make sure you have n done this or you will have issues.
Do you get the error code while programming or after programming? E4491?
Do you get the U185a prior to programming the BECM or after the programming error?

Error E4491 i get on 1% of status bar !!! On 3116 bytes !!! .. DTC Code U185A get after programming error . Because BECM is lost connection after programming is stoped and not finished correctly . Flash is erased and not programmed.
 

·
Registered
Joined
·
307 Posts
A few more questions.

1. Are you in service mode or is the ignition on?

2. Are you doing this wireless from your laptop to the MDI or are you using a cable connection between the 2?

#3. Are you using a new BECM or a used part?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
A few more questions.

1. Are you in service mode or is the ignition on?

2. Are you doing this wireless from your laptop to the MDI or are you using a cable connection between the 2?

#3. Are you using a new BECM or a used part?

1. Yes in service mode . ( hold power button for 5 sec and service mode is on )
2. No ! I have USB connection .
3. Replaced BECM is Used but with my BECM is identical problem with programming .
BECM of this car was reprogrammed and died and then replaced used BECM then replace/reprogrammed and take same situation
 

·
Registered
Joined
·
307 Posts
I know its not easy to keep replacing the BECM, not sure if you are going to have to replace it again. GM recommends after a program failure to try and program again prior to replacement. You may try and program the BECM again but this time where it asked you if you have a new module or updating a old module, go with a new module. When you use the update (a normal process when just reprogramming) the system looks for the software number. If it can not find the number, it will not try to program. When you program as if you replaced the module, it does not look for the software number and it will just try and program.
If you are already doing this or after you replace the BECM, before you program under update (not replace new module) the system should pull up the software number before you get to the actual programming. Make sure it can pull up this information. This will let us know if you can talk to the BECM thru TIS. If you can not get the software number to show up, there is a comm problem. Also if you do replace the BECM with a used part, then prior to doing any programming try and get some data with your scan tool to make sure there is comm with the module.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #8 · (Edited)
I know its not easy to keep replacing the BECM, not sure if you are going to have to replace it again. GM recommends after a program failure to try and program again prior to replacement. You may try and program the BECM again but this time where it asked you if you have a new module or updating a old module, go with a new module. When you use the update (a normal process when just reprogramming) the system looks for the software number. If it can not find the number, it will not try to program. When you program as if you replaced the module, it does not look for the software number and it will just try and program.
If you are already doing this or after you replace the BECM, before you program under update (not replace new module) the system should pull up the software number before you get to the actual programming. Make sure it can pull up this information. This will let us know if you can talk to the BECM thru TIS. If you can not get the software number to show up, there is a comm problem. Also if you do replace the BECM with a used part, then prior to doing any programming try and get some data with your scan tool to make sure there is comm with the module.

Now i have replaced used module in it. I can change it again to my module .
When i replaced used module i tryed ( replace and programm ) after i have error
I have not new one !!!
If you can tell me what i need to do i will ver happy .
I can buy time on gme-infotech and give you remote access to my pc if you want.
Now BECM talk with TIS but can not reprogramm. Did you see video which i posted ?

Now i post last photos when i reprogram . But today i try to reprogram how you recomended. If you can and have time i can give you remoote access by TeamViewer
 

·
Registered
Joined
·
307 Posts
I see that you are not using a GM MDI interface tool, not sure if this is the issue or not. Have you programmed another GM car with this system? You have performed the procedure correctly so I am not sure whats going wrong. At this point you would have to call tech support at the TIS website to see if there is something wrong on there side. I would not be able to use the remote access here because my dealership has a firewall that will not allow me to do many things.
If you call the help desk, make sure you have the error code and also there is some more information they may need when you scroll down on the error code page.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #12 · (Edited)
I see that you are not using a GM MDI interface tool, not sure if this is the issue or not. Have you programmed another GM car with this system? You have performed the procedure correctly so I am not sure whats going wrong. At this point you would have to call tech support at the TIS website to see if there is something wrong on there side. I would not be able to use the remote access here because my dealership has a firewall that will not allow me to do many things.
If you call the help desk, make sure you have the error code and also there is some more information they may need when you scroll down on the error code page.
Hello . Thanks for reply .
I was reprogrammed K10 module and K114B module by this interface tool without any problems .

One question - maybe i need to change HPMC2 module ?

Can it be problem for reprogramming BECM ?


I tryed contact to costumer service and they tell me, in your location you can contact to Turkey service . I no need to contact with they because Turkeys do not know anything about Chevrolet Volts .

Before i was reprogramm BECM i had this codes too , P1EBF and P1EC5
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #14 ·
BECM Reprogramming error is SOLVED !!! Problem was in scan tool Abrites AVDI !!! Can not reprogram only BECM . All other computers can be reprogrammed by Abrites , but cannot reprogramm BECM .
 

·
Registered
Joined
·
12 Posts
BECM Reprogramming error is SOLVED !!! Problem was in scan tool Abrites AVDI !!! Can not reprogram only BECM . All other computers can be reprogrammed by Abrites , but cannot reprogramm BECM .

As I am facing almost the same issue could you please kindly support me.
I am using VCX Nano for SPS programming and after programming BECM and K1 I have lost access to DC/DC module with U1821 error. APM stopped feeding with 14v when car is on.

What kind of instrument did you use to program "dead" module? Any trick behind?
 

·
Registered
Joined
·
2,360 Posts
1 - 16 of 16 Posts
Top