GM Volt Forum banner

Mysterious call on hold preempts all music and HVAC

1465 Views 8 Replies 6 Participants Last post by  quirkySquirt
So the myLink annoyances continue, but this one is not so minor. Starting a day or two, every time I start my Volt I first get whatever I was last listening to. But very quickly as my phone connects, the music stops and HVAC level goes way down like I'm receiving a call. And who am I calling, you ask?

Apparently.... me.

And I guess I'm on hold. It seems like they could at least offer me some hold music.

But when you click on my call, it turns out I'm not really on hold:

You can try to end the call, and the count-up time will stop, but nothing else changes. You're still locked out of music and HVAC.

The only way I've found to fix it is to start streaming music from my phone. This "ends the call," and I can then switch to whatever source I want.

Did I mention the car is doing this 100% of the time? Ugh. Anybody else experienced this? I'm using an iPhone 6 with latest software (9.3.2 if memory serves). Volt is a Dec 2016 buid.

See less See more
1 - 2 of 9 Posts
That is so weird. Is there a dialing sound? I've never actually used the mylink dialer and always used the Android Auto dialer. In the mylink dialer, does it make dialing sounds? AA dialer most of the time makes dialing sounds so I know when I'm initiating a call.

Also, perhaps the phone is checking your voice mail? I think you can check your voice mail by calling yourself from the phone assigned to the voice mail. Perhaps this is why it looks like you're calling yourself? Still doesn't explain why no voice mail prompts or anything, just lowered HVAC and muted music.
I had a problem that was solved in a similar way, now that you mention the fix. My Sony Xperia Z3 Compact was always defaulting to answering calls from Android Auto via the phone's speaker vice the Volt's bluetooth. I did exactly what you did, minus the failed pairings, and a reboot of the phone followed by a successful pairing fixed everything.

I also have auto updates turned off on my Android, so maybe I needed to keep AA updated (have encountered warning about AA not working until I updated AA).
1 - 2 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.