GM Volt Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,201 Posts
Discussion Starter · #1 ·
I only have had my 2013 Volt with MyLink/Navigation for two weeks and my nav system has gotten stuck twice on the "Calculating route..." screen.

I can display the radio, climate, and config screens, although I can only see the outer edges of those screens because of the "Calculating route..." message. I turn the radio/center stack off and on and it comes back on, still displaying the message.

I tried using voice control to cancel the route or to start a new route, but the voice tells me that it can't because the system is (you guessed it!), currently "calculating a route". I called OnStar and they tried to send a destination to the car. Nothing happened. Still stuck. They have no idea.

I stopped and turned off the car and quickly restarted it. Still stuck.

I finally turned off the car and waited a few minutes before starting it again and that "fixed" it.

This has happened twice in two weeks and the only common thread was that both occurrences happened on an abnormally hot day. The car had been sitting in a hot parking lot all day when I was trying to navigate after work.

Has anyone else experienced a stuck navigation system?
 

·
Registered
Joined
·
1,269 Posts
Never had the problem. My NAV works perfectly.
 

·
Registered
Joined
·
1,201 Posts
Discussion Starter · #5 ·
My navigation system wasn't working one morning and I was stuck in really bad traffic. . . . Also, for those that are curious, that did not fix the Navigation system bug that morning.
I know this is an old thread, but I'm experiencing some navigation issues myself. Do you still have problems with yours? I do. Read about it here.
 

·
Registered
Joined
·
219 Posts
This happened to our MY2013 just a mere hour after driving it off the lot. It never happened again after.
Hopefully they issue an update to fix an obvious software lockup bug in the navigation module, or they should configure the watchdog module to kill the navigation processes if they hang up like that so they can restart. (Like they do already for crucial stuff)
I would call it an annoying issue since the "calculating" box covers everything else until you reboot the whole center stack.
 

·
Registered
Joined
·
1,201 Posts
Discussion Starter · #9 ·
...an annoying issue since the "calculating" box covers everything else until you reboot the whole center stack.
Short of turning off the car (and waiting a few minutes since turning it quickly back on doesn't completely reboot the system), is there another recommended method to reboot the center stack/navigation?
 

·
Registered
Joined
·
4 Posts
I've had this happen twice in the last month. I had to power off the car, and open the driver door to get it to reset.
 

·
Registered
Joined
·
77 Posts
Happened to me, nav was completely stuck, didn't have a chance to turn off the car and leave it off for long so I had to find my way on my own. Another issue I had was that I was searching for POIs and the search was hanging and nothing navigation related would respond.
 

·
Registered
Joined
·
105 Posts
I still get this on occasion on my 2014 even after the latest system updates from the dealer.

I believe it only happens on occasion when sending directions to the car from the onstar app ( is anyone able to confirm that part? )

And yes a reboot function would be amazingly useful as you have to leave the car for 5-10 minutes after shutting it down for the issue to clear. My concern is if it's a bigger issue or just an occasional glitch.
 
1 - 15 of 15 Posts
Top