GM Volt Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I'm getting an engine and the code came back with U1510. Autozone says Lost comm with sensing diagnostic module fault code. Onstar says generic code engine and trans take to service within 7 days. I cleared the code and it comes back. Everything seems to be functioning perfectly. Any ideas before I take it into the local Chevy dealership and fork out $100 for a diagnostics
Thanks in advance!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
When I took my 2016 VOlt into the dealership and they ran a diagnostic on it. It came up "CODE 1510 Lost Lin bus to active grill shutter.
 

·
Registered
Joined
·
3 Posts
Same problem for me, code U1510 show with my OBD reader. Dealer have more specific code that guide technician to the active grill shutter. The wiring near the grill motor was dommaged by corrosion. Corrosion on a 2 years old car :(
 

·
Registered
Joined
·
669 Posts
Same problem for me, code U1510 show with my OBD reader. Dealer have more specific code that guide technician to the active grill shutter. The wiring near the grill motor was dommaged by corrosion. Corrosion on a 2 years old car :(
Anyone with pics or details....I'd like to be able to locate this "grill motor" and shutter system on my 2017 Volt.
Thanks!
 

·
Registered
Joined
·
8 Posts
Just got the same U1510 on my 2017 LT. Can't get to dealer until next week. Had a ton of snow here and the CEL happened after I backed out of my driveway into the street through a bunch of crusted snow. I cleared it several times and it comes right back. Car runs the same. I crawled under neath but didn't see any obvious broken wires or sensors but could not see much. Did not remove belly pan but it didn't really look like that would help. Any suggestions? If removing BP will help, I can certainly do it but what/where should I look when I do? Thanks
 
1 - 6 of 6 Posts
Top