GM Volt Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Add me to the list of failed 2012 EVSEs. The EVSE that came with my used 2012 Volt was hardly (never?) used itself. However, I used it daily for a month and KAPUT!

I've seen plenty of past forum discussions about 2011,12 EVSEs that have died. But what I haven't seen is if the more recently manufactured EVSEs have a better survival rate (nobody writes when things work as intended). After this, I intend to get an L2, but I'd still like to know if my replacement GM EVSE is going to last.
 

·
Registered
Joined
·
2,867 Posts
I use mine about once a month. That probably explains why mine in still working.
 

·
Registered
Joined
·
3,549 Posts
my original has been in use 24/7 for 3 Plus years

i think the reason it is still working is I have a spare new unit ready to go in the car.
 

·
Registered
Joined
·
3,080 Posts
My 2012 stock EVSE is still plugged into my garage and working fine.
 

·
Registered
Joined
·
521 Posts
I use my 2013 every night for almost exactly 2 years now. Still running well.

About to go the L2 route at home though, so it should basically go into early retirement. Fingers crossed!
 

·
Registered
Joined
·
191 Posts
I used the one that came with my 2013 Volt for about a year through one winter before retiring it back to the trunk for an L2 Clipper Creek charger. Winter here is hell on chargers through considering our crazy freeze / thaw cycles in the spring, salt water, snow and ice. When I first got my L2 Clipper Creek charger I assumed it would be as durable as my original charger. Boy was I wrong. In the spring, I suspect a freeze / thaw cycle probably broke through the seals and salt water leaked into the charger frying it. Clipper Creek was good on their warranty thou and admitted their charger isn't meant to be used in those kind of conditions so now going through my second winter with new L2, I encased the whole thing in a tupperwear container and sealed off the openings with a lot of silicone making it more weather proof. So far it's working and my charger stays dry and clean despite our crazy weather.
 

·
Registered
Joined
·
172 Posts
Funny this post should show up today. I pulled in my garage last night, plugged my EVSE into my 2012 and heard a click, then it died. No lights at all. Unplugged, replugged, checked the outlet, etc. Nothing. This is my second EVSE and now going to the dealer tomorrow for a third. Will my replacement be a more robust Clipper Creek made model or a refurbished Leer version? My warranty is going to expire in June so I'd really like this EVSE to last the life of the car. I briefly considered an L2, but I'm not sure it necessary.
 

·
Registered
Joined
·
139 Posts
2013 here with 3.4k miles. No problems with the GM supplied CC L1, or the CC LCS-20 L2 I purchased for home. The GE L2 at work has been good, except someone broke one of the J1772 handles by catching the cord with the car when pulling out and breaking the handle...parts on order.
 
1 - 12 of 12 Posts
Top