GM Volt Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello everybody. I am new to the forum, I have been reading it for years to get info but never had to start a thread because all the answers I was looking for were already there. So my center display started to freeze time to time about a year ago. It would freeze completely for 2 or 3 minutes and then all the touch that I had done while it was frozen would catch up and then all would be normal. Then months later it got worst, the display would stay dark for 5 minutes when I would start the car, the radio would turn on but no radio control would work. After the 5 minutes or so the display would turn on but would show only a dark background with error code of some sort and the radio buttons would work again. I tried to unplug the battery to reset the system and it worked a couple of times, checked the fuses etc... but no permanent fix

A couple of weeks ago I decided to go to the dealer and the mechanic thought it was the display and order one. The part came in last week but obviously my appointment is only in 2 weeks so I decided to try stuff. A good friend of mine has the same car so I tested my display on his car and it works like a charm so the mechanic seem to be wrong and now I am wondering what else can be the problem. Could be the radio but maybe something else and I would really prefer to have an idea before I bring it back to the dealer and let the mechanic spending hours on it. I will try to add a picture, hope someone will have be able to help. Cheers
 

Attachments

·
Registered
Joined
·
2,014 Posts
Replace your 12 volt AGM battery.
 

·
Registered
Joined
·
2,014 Posts
Thanks, I will look into it. Does the error code gave you a clue?
Actually I’ve never seen that error before, but my screen would just reboot at random times. After replacing the original 5-year old battery, it’s never done it again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 · (Edited)
Try to replace the AGM battery (I have the same model on my other car) and same result. looks like my next try is to replace the radio but a used one would need to be program at the dealer. This will be my next move unless someone has a better idea.

Update, just order a used unlock radio, next step is to install and check if it was the problem and if the radio needs some programing.
 
1 - 5 of 5 Posts
Top