GM Volt Forum banner

Bricked my Instrument Cluster, could use some help.

12503 Views 27 Replies 10 Participants Last post by  Tjdupaix
While attempting to update the Instrument Cluster I didn't realize that the vehicle USB port that the update mentioned was not the one in the center console but was actually a USB port on the back of the cluster, now the cluster reads a continuous loop with the words: "IPS_MSG_CTRL (Activated)"
I have tried re-applying the update with the USB drive plugged into the cluster and it fails every time, I have tried to re-program the cluster as a new ECU but there is no communication, I have also removed the cluster wire connector and let sit for a couple of hours and nothing.
Just curious if anybody else has done this and recovered from it or if a new cluster off Ebay is in order?
Many thanks
I also know that GM recommends not to flash updates unless needed, I was hoping to resolve an issue in which the screen stays blank on start-up.
1 - 4 of 28 Posts
I know this is an old thread but can someone explain how the .bin files get loaded to usb. Does SPS2 create the bin file on the computer usb or usb attached to cluster. I have bricked my cluster attempting to upgrade code but had the usb in the console not behind cluster with cable. Please help
Thank you twowheeldrive,
I will keep trying this, just a little confused as to where the flash drive needs to be to download. Bin file.
Thanks again for the response.
Si I've tried 3 different usb sticks format in fat32 and ntfs with no luck. I actually get a E4492 Cyber Security Access failure and E4423 Unknown reprogramming error 5 at step 0 error when attempting to program cluster with SPS2. I don't know if I can get a bin file from somewhere else to attempt the program as the cluster does recognize the usb when I plug one in but says no 22923964.bin found. I might have to call the acdelcotds helpdesk on Monday. I did turn off my antivirus and windows firewall with no luck. Thank you for the advise i've received so far.
Yes I did.
When you are in SPS and go into instrument (cluster) make sure you select the 1st step and insert a thumb drive onto laptop. I was caught up in a circle trying to perform step 2 as SPS thinks step 1 has been completed.
In the menu, highlight step 1 and this will download the correct bin file from AC delco, then continue with step 2 in inserting the thumb drive onto special cable in instrument cluster.
Good luck, but it should work.
  • Helpful
Reactions: 1
1 - 4 of 28 Posts