GM Volt Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
12 Posts
I feel lucky. My 2017 with 49K miles started acting up on Mon 5/23. it was showing multiple error messages including "reduced propulsion" and the fully charged battery showed a 1 mile range. When I tried to put it into gear, it showed the "shift to park" message, which was weird. Doubly so since I had already had that done. Whatever I did it would not move on it's own. At first I thought it might be the 12v battery so I went to Costco and got one. Put it in. Of course that was not the cause. I called the dealer and scheduled a service. I had to call a tow company who flat bedded it to the dealer. Once there, they looked at it a declared that it was the BECM. Ugh, I knew that was bad news. They mentioned having another customer who had been waiting Since mid-April for the part.

They offered to give me a loaner, but when they checked with Enterprise, Enterprise didn't have any cars and was waiting for some to come in. That was doubly funny. Fortunately we have another car and were able to coordinate who used what and when. I was prepared to have to wait it out for weeks.

Then, in the first week of June, the dealer called and said that they were getting some parts in and thought they could get mine fixed. A couple of days later and only a little more than 2 weeks since it failed, it was fixed and I was able to drive it home. I feel lucky that the timing of the fresh supply was just right for my car.
 
1 - 1 of 1 Posts
Top