GM Volt Forum banner

2013 Volt - Intermittent charge issues

8439 Views 49 Replies 13 Participants Last post by  lexcyn
So here's a weird issue that I can't figure out. Periodically I will take a short drive in the morning (maybe 10km or so), then come home and plug in. Yellow light will stay on and I will get the message "Unable to charge" and my range is now down to 0. Turn the car on and get the "Service High Voltage System" and "Propulsion power reduced" messages. OK. Remove 12v negative, put it back, messages are gone, car will charge fine and range is back to where it should be, no issues.

I just replaced the 12v battery with a new one thinking that was the problem, but it still persists. This has happened to me twice in the past month, always in the morning. I'm wondering if it could be my L2 charger (using an Nissan unit) or maybe the dreaded coolant sensor issue?

Dealer had "fixed" this in the winter by "reprogramming" the battery computer but I'm assuming they just reflashed it and it reset the errors.

The only codes I could get were from a check engine light that I normally receive when there are power quality issues with charging (P1E00 & P0D22). After I reset the 12v there are no codes and everything works fine.

Specs:2013 Volt, 106,000km, L2 charging ( Nissan unit @ 20amp) plugged into 30a dryer plug

Help! :)
1 - 20 of 50 Posts
It may not being related at all because I had no such "Service High Voltage System" or "Propulsion power reduced" messages but just in case:

Last year my 2013 had intermittent charging issue with different L2 charging stations. The EVSE had a ground fault issue (refused / stopped charging) when temperature was damp wet due to the cracked J1772 connector on the Volt side, as reported to me by my dealer. Once connector replaced, the problem never came back.

If you have power quality fault codes at home, make sure your electric installation verified by your electrician...
Thanks for that info - the plug I am using has no issues (verified by electrician). The dealer did check the car and said there was nothing wrong other than to flash the HBCM or whatever which did remove the codes, but obviously not the problem.

Coolant level is *not* above the black label, it's in fact just below it. Does that mean I need to add some? I did order the level sensor defeat plug not too long ago.

The "Unable to charge" message just happened again this morning, removing 12v and resetting computer fixed the issue *again* and car is charging fine now on L2 (just drove 70km and got home with 3km left!). No idea what is going on. Wish the dealers around here would spend more time looking at the car but they just go to their code screen and fix that way.
Rule out the EVSE by using the stock 120V unit immediately after such a failure.
If it fails on both you've determined it's either 1) car or 2) house power
Since you're familiar with the issues that happen with poor grid power, this is likely not the case - I would guess car needs to go in for service - drive it to the shop with those error messages on screen so they have it with computer info in hand. 12V reset will erase the logs.

Coolant level would throw a different error message - service high voltage charging system, which sounds like you're not getting.
Your coolant level is ok, but not ideal. It should be at the black label, but it will go down over time with evaporation.
Thanks, I will try that next time. The error did occur with the stock 120v charger back in the winter time and that's when I drove to the dealer in "limp" mode. I think it could be the onboard charger as it seems to be worse using L2 chargers (more current = more chance for failure?). I just wish there was a code or something they could check electrical wise to determine if that's the point of failure - but I know they will charge me $ to diagnose the issue if there are no codes since I am just on the extended Voltec warranty now.
My onboard charger worked fine with the stock L1 EVSE and then I bought a used Bosch L2 and it failed. Plug the L1 in , yellow, green, beep. Plug the L2 in yellow and nothing else. My dealer started the troubleshooting process by replacing the charge port, made no difference so they then ordered the on board charger. Bingo.
Were you able to get it going by resetting the 12v battery?

That sounds like the issue I am having... which is why I also suspect it's the onboard charger as well. I am going to bring it in to the dealership on Monday - even if I have to pay a $120 "diagnostic" fee I know the part would be covered under the Voltec warranty anyways.
A thought: what current setting do you use when charging? Does the problem occur with the 8 amp setting?
I'm using a L2 charger... but I was always using the 12a setting on the L1 charger (I was using the L1 Voltec charger as well as the L1 setting on the L2 charger I have, problem only happened once on the Voltec one).
Just an update: we had an electrician come out and check our house, the EVSE, etc and everything was fine. He thinks it's most likely the car.

I've got it in at Chevrolet today and they are specifically going to be "testing" the charge port and on-board charge unit - not sure what they will do, but I'm sure they have something in the service manual they can test with.
Just an update again: dealer just basically re-flashed the battery control module again with the same version that was on it. I told them this had already been done previously so they said if the issue happens again they will be replacing the charge port and the on-board charger (like I suspected). Crossing my fingers it happens before my Voltec warranty expires in 53,000km.
It did it again just now. I had about 53km range left, turned car off and plugged in, got an orange light and unable to charge message. Turning car on gives propulsion power reduced and 0km battery, and of course a check engine light.

It seems this only happens if I plug the car in when a door is open, but maybe my mind is playing tricks on me since there doesn't seem to be anything wrong with the car before it happens.
OK so this is even worse. I decided to drive it to the dealer. Well, driving with no battery is ridiculous - no power whatsoever. I pulled over and turned the car off then back on, and what do you know, I had some battery. But not the 53km I should have had... it was around 33km, then it went down to 4km, then back up to 30km, then jumped from 20-30 then settled on 15km??? These symptoms make me think there is a bad cell in the main battery.

Anyways, I made it to the dealer. I'll see what they try and tell me isn't wrong tomorrow. :p
Had the same problem with my 2013, intermittent 240V problems but OK on 120V.

They replaced the charging port on the car. Problem never came back. They never flashed anything in my case. It was a hardware issue with the charging port.
I tried the L1 charger and a different L2 charger and after I get the first "Unable to charge" message the car won't accept another charge until I either remove the 12v power or they reflash the HBMC.

I'm starting to wonder if it's something more sinister than just the chargeport, but they said they would start with that first. The fact that the battery capacity was jumping around and I somehow lost about ~50% charge in the matter of 1 minute seems like something is shorting out, or there is a bad cell in the main battery. Whatever it is I just hope they figure it out quick. I've now had this car at the dealer more times than any previous car I've owned and I've only had this car 6 months. :(
Well another update:

Got the car back from the dealer. Volt tech said the last firmware update didn't fully complete and some blocks were bad. They also reflashed some other computers, not sure what.

This is what was on my invoice:


Unsure what this means, but they said it was a different code from last time... no parts were replaced.

Car is charging now so I guess we'll see if it lasts.

EDIT: Just read the service manual and it looks like there were a bunch of voltage tests supposed to be performed after the reset, with them ultimately replacing the power inverter or the battery pack - so I'm guessing this isn't the last time this issue will happen, great! :(

EDIT 2: I feel like I am talking to myself ha! I found this link to a post WOT made: ... I will have to print this the next time it happens.
See less See more
Just another fun update. Car did it again this morning. I guess it's another trip to the dealer ... whatever they did didn't even last 48h. Not a happy camper.
Dealer just informed me they had to order a "volt diagnostic toolkit" which has some high voltage monitoring equipment that they did not have... no ETA on this kit and my car is stuck there and they won't provide a loaner because technically they haven't diagnosed the issue yet.

I think this will be my last GM!
That is BS. They may not know the reason for the problem, but they can certainly see the problem. It's their fault they don't have the proper diagnostic tools. Is there no other dealer to whom you can take it?
I completely agree with you there but I don't have much of a choice. I don't want to drive it and them come back at me saying I made it worse by driving it. I'm wondering if since I have a call into the GM customer service line they will cover a rental for me while they get it sorted - this just screams terrible customer service to me if not.
So I've been speaking with a GM Volt Ambassador about this and they seem to be on it. They've agreed to reimburse any gas expense I have because of the issue as well, which is nice.

In any case I've picked the car up and this is where things start to get a bit strange. So the MIL was on which was expected, but also I seemed to have about 80% battery range again. I drove home last night and left it sitting until my off-peak time and decided to try plugging it in. My understanding was due to the specific code (P0AF8) it locks out the vehicle charging to prevent any further voltage issues with the battery. Anyways, I plugged it in and low and behold it started to charge fine. It completed the charge and what do you know... the MIL has disappeared! And this was all without resetting the high-voltage system to clear any codes, so I am really confused at what is happening.

In any case the dealer will have their equipment on Friday and I will be leaving it with them to see what they can find out (they didn't have the high voltage gloves).
See less See more
They replaced the charge port yesterday - today leaving for work, car powers off and reboots while driving, lose all power steering/brake assist and a bunch of messages like Engine Not Available, Service Soon; Propulsion Power Reduced; Service Front Camera; Service Charging System, etc lit up. Turn car off and back on, everything is fine. Drive for a few hundred meters and boom, reboots again.

I don't know WTF they did to my car but I had it towed to the dealership.

Note: I don't think it would be a 12v battery issue, I replaced it last month with a brand new one.

EDIT: Uploaded a video of it happening:
Turns out it was the 12v fuse block. When they disconnected it to replace the charge port it wasn't torqued back to spec and was loose, causing the intermittent loss of power. Makes sense, but crappy. I'm hoping GM will pick up the tab on the towing bill to get me there.
So an update again... this morning back to the original error. Propulsion Power reduced, CEL (P0AF8) and just engine power. I turned the car on/off a few times and was able to get about 3km of range on a FULL charge (it was fully charged before I went to sleep).

I'm hoping WOT can chime in eventually since I remember reading a thread about this same error before.
I don't think that the dealer's Voltec Technician got an A in the course... just guessin'
Haha I don't think so either.

So later that day it stopped saying unable to charge and I was able to charge to full. After doing a couple small trips and charge top ups the MIL is gone. Could this be a HBMC2 issue? It almost sounds like that since the way it can't seem to figure out how much battery is available after it gives the error.
My last visit to the dealer (yesterday) resulted in them saying the tech did not follow proper procedures after disconnecting the HV battery. There was apparently some procedure to "relearn" which involves reprogramming a bunch of computers including the HBMC2.

Anyways it seems to be fine ... for now. I'll keep this thread updated.
1 - 20 of 50 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.