GM Volt Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
2013 Base Volt 101,744 miles. Looking for ideas, and Dealer recommendations.
Starting around maybe December of 2020 I started getting the "unable to charge" dash message and solid yellow dash light with code P0AF8.
It would charge intermittently on it's own. Like it would charge fine a week, and then throw the error.
I replaced the charge port, and the dealer changed the main charge module. (Charger) The charge module change was over $2000.00. Problem still exists.
The dealer wants to change the charge port again, but it seems to me if the port had issues it would just stop working completely. I don't want to have them just throw parts at it to see what sticks.
For awhile I could clear the code and get the car to charge, but now even that won't work. The battery charges in mountain mode with no issues.
Any ideas on what to have the dealer check for? Also, does anyone have any recommendations on a good dealer with a good volt tech near Madison WI?

Thanks so much for any info you have. Driving with gas is so frustrating.
 

·
Registered
Joined
·
793 Posts
If it will charge up in mountain mode and maintain something like 14-18 miles range on the guessometer, then either the charge port or the on board charger which you have already done, are main suspects. Have you tried strange EVSE? Maybe the problem is with your factory L1 EVSE. You most likely have trued using the dealerships EVSE right? I think the dealer is on the right track, throw another port at it. If that doesn’t work throw another on board charger module at it. It it still fails possibly a loose wire connection or something.
 

·
Registered
Joined
·
41 Posts
Changed charge port, changed on board car charger ( behind front ride side of front bumper), testes cable from charger to battery and went through the diagnostics of p0af8 checking cable voltage differences and checked reaistence between cable from on board charger to batter.

The car even charged for a few times after installing the on board car charger and now back to square one.
 

·
Registered
Joined
·
45 Posts
Common Problems That Trigger the P0AF8 Code

Auxiliary 12V battery failure
Battery Energy Control Module (BECM) failure
High voltage battery assembly failure

you would need to observe traction battery voltage in real time with GDS2 when this happens to troubleshoot.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I was actually going to follow up on this thread. My car is at the dealer now for this issue. I had been having luck getting the car to charge by clearing the code and repeatedly restarting the car with the charge cord plugged in but that stopped working also. Anyway.. the dealer is changing the HV battery contactor/relay assembly at the front of the battery. (Part 24297383) cost $2442.15. It is supposed to be done Friday. I hope this does the trick. I will follow up with details.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
I can't imagine that assembly goes bad that often. I'm hoping I'll be good now for another 100,000. Battery cells look good. I just changed brakes all around. Passenger side hub assembly was just changed with the brakes. Crossing fingers I get a couple more years out of the car at least. Waiting for an electric truck
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Car is back home. First charge at the dealership went well. I have set my first charge as a delayed start so I'll see what happens in the morning. Crossing fingers.
 

·
Administrator
Joined
·
22,489 Posts
Anyway.. the dealer is changing the HV battery contactor/relay assembly at the front of the battery. (Part 24297383) cost $2442.15. It is supposed to be done Friday.
$575 with core charge. The other $2,000 must be labor. At $160/hr., they spent 13 hours dropping the battery and replacing that relay?
 

·
Registered
2012 Std w Nav
Joined
·
5,079 Posts
I don't think we've ever heard of anyone getting the car back same-day for this kind of operation. 13 hours doesn't sound alarmingly out of scope.
 

·
Registered
Joined
·
38 Posts
I just had the HV Battery Disconnet Relay #24297383 replaced under warranty. I have not been able charge the battery on L1 or L2 chargers for a couple of years. But the battery would take a charge in Mountain Mode. 2013 Volt. Car has been to the dealer over a dozen times in this time period and they never could find anything wrong with it. It would charge there but not charge at home or at commercial L2 charge points. Finally had the car start up in reduced power propulsion mode and stay that way as I drove it over to the dealership. Primary code was P0AF8. Finally the code stuck for the technician to troubleshoot the problem.

But it took 20 days for the dealership to get the replacement part from GM as anybody that had stock would not release it because they needed it for their own repairs. Took a district manager to have enough weight to pull it from somewhere. Just got the car back and charge was exhausted by the time I got home but I have the car on charge now and it hasn't thrown any codes yet and is still charging. Hope this finally fixes the car.
 
1 - 17 of 17 Posts
Top