GM Volt Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
The cruise control on my 2012 Volt will not work anymore. It started off about a year or so ago just shutting off while driving, but now, it doesn't work at all. The green indicator light will still turn on in the instrument cluster, but when I try to set the speed, nothing happens. Any thoughts on this problem?
 

·
Registered
Joined
·
2,337 Posts
The cruise control on my 2012 Volt will not work anymore. It started off about a year or so ago just shutting off while driving, but now, it doesn't work at all. The green indicator light will still turn on in the instrument cluster, but when I try to set the speed, nothing happens. Any thoughts on this problem?


Have you attempted to replace the switch?:confused:
 

·
Registered
Joined
·
2,337 Posts
If the DIC indicator turns on, what makes you think it's the switch to turn it on is the problem?


Only because I have had to replace the right switch already on my Gen1. This is the switch that controls volume/song selection ect. due to tracks just suddenly switching on their own w/o any input.

Figured it would be just a matter of time until the left cruise control switch may fail since it is of the same resistor-ladder type as the right. This would be simpler/cheaper than replacing and performing a follow-up programming on the K9 BCM [email protected];)
 

·
Registered
Joined
·
3,172 Posts
try pulling up on your brake peddle and try to engage cruise
The brake pedal issue will also cause the cruise control indicator to go out.
 
1 - 8 of 8 Posts
Top