GM Volt Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 · (Edited)
edit: 2012 with almost 100,000 miles

I had the car die in the middle of the road after a long full-throttle acceleration to get up to highway speeds, the day before we were supposed to move out of state. So we delayed our move and took it to the dealer. They said "Loss of Propulsion Due to Low Cell Voltage N172130462-02" had not been done. I guess I got mixed up with our Bolt, because I could have sworn it had been done. So they reprogrammed HPCM2, and I talked to the tech to ensure the car was good for a road trip.

100 miles from home, same thing happened. So I got a uhaul and a car hauler and I pulled the Volt to our first stop at my in-laws. There I used a VCXnano to see that it was in fact P0AFA again and I reset the HPCM2 again. I still needed to get the car to my parents house, so I used the myVoltHold app to keep the battery around 80% SOC. We successfully drove about 300 miles in "hold" mode.

Now that we're here I ran the battery down just to see how it would act in gas mode, and how easy it would be to throw the code again. As soon as it switched to gas I got PPR and ... you guessed it... P0AFA. I pulled some data this time:
170663


170664

170665

170666


So, how F*ed am I? What should I try next? What batteries are swap-able between years? Any insight at all?

Thanks!
 

·
Administrator
Joined
·
21,121 Posts
Model year? Miles?
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #4 ·
A little more information, if for no other reason, to chronicle my own realization of a financial disaster. After all, who drops $11 grand on a car and expects it to replace it in two years? Nobody.

Fully charged voltages:
170670

170671

170672


And here is the BECM data screen:
170673


Any idea why the 5V reference voltage is 3.00V? A 5V reference would lead me to believe that it should be 5V, no? Is that normal?
 

·
Registered
Joined
·
151 Posts
Have you check the condition of the 12V battery? It appears that it could cause error P0AFA.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #6 ·
Data collection while under load, blue = cell group 1 (control), green = cell group 5

170681


Freeze Frame Capture, showing cell group 5 got down to 1.6v causing P0AFA (again)
170682


Yay! My battery is ****ed
 

·
Registered
Joined
·
67 Posts
@wrillo I have the same issue how did u fix temporary to start up ? I had the same issue and I need to start at least for a while until get the replacement of the battery, my idea is to use hold mode app (myvolthold) but I need to start the car right now has 11% SOC and P0AFA DTC is currently
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #9 · (Edited)
You must use a VCXnano (or equivalent tool) to reset the code in HPCM2. I am now using mountain mode to maintain a safe voltage level. My fully charged range is now down to 19 miles, but it is winter weather.
 
1 - 9 of 9 Posts
Top