GM Volt Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
I have been using my 110V charger for the past year with no issues, but starting yesterday it no longer works -- the flashlight stays lit all the time (as if the trigger is being pulled), and the Volt doesn't beep when the charger is inserted. I tried unplugging it for 15 secs but same result.

Anybody else ever experience this issue or know of a fix? Any idea what a replacement charger will cost from the dealer?

(Note: this charger is the new one I got from the dealer in 2012 after they recalled the original 110V chargers.)
 

·
Registered
Joined
·
516 Posts
Mine failed a couple years ago. My dealer provided a new one on warranty. All Voltec equipment has 8 year / 100K coverage. The EVSE is considered part of the Voltec equipment.
 

·
Registered
Joined
·
137 Posts
My 2012 charger does that sometimes when it's cold. I just push the latch down so the light goes out, and then push the charger on without pulling the trigger, and it usually starts charging.
 

·
Registered
Joined
·
2,130 Posts
I have been using my 110V charger for the past year with no issues, but starting yesterday it no longer works -- the flashlight stays lit all the time (as if the trigger is being pulled), and the Volt doesn't beep when the charger is inserted. I tried unplugging it for 15 secs but same result.

Anybody else ever experience this issue or know of a fix? Any idea what a replacement charger will cost from the dealer?

(Note: this charger is the new one I got from the dealer in 2012 after they recalled the original 110V chargers.)
First stop should be the dealer, they may cover this under the Voltec warranty as mine was. Looks like you are in California? I believe the Voltec warranty is a touch longer than anywhere else in the USA. How many miles on your 2011?
It's worth a shot :)



(Note: this charger is the new one I got from the dealer in 2012 after they recalled the original 110V chargers.)[/QUOTE]
 
1 - 6 of 6 Posts
Top